MENU

typecho升级到PHP 7.2后报错Database Server Error

February 23, 2023 • Read: 713 • 日常折腾

最新版typecho1.2对于PHP版本的最低要求是7.2,要升级typecho就只能先升级PHP版本。

  1. 宝塔软件商店安装需要的PHP 7.2 版本
    222.png
  2. PHP版本管理点击切换
    111.png
  3. 回到typecho刷新页面,会发现打不开了
    1.png
  4. 找到根目录下的config.inc.php文件

    将"Mysql"修改为"Pdo_Mysql"大功告成

2.png
3.png

Last Modified: March 3, 2023
Archives Tip
QR Code for this page
Tipping QR Code
Leave a Comment

2 Comments
  1. 好像也遇到过这种情况~

    1. @Mr.Chou所以特地记录一下::@:11::